Error connecting to server https://translate.google.com Try again.“)

  • Step 1.
    if you already have version 6.19 installed — skip this step
    for others:
    Download and install the latest official signed version:
    https://www.dropbox.com/s/6cyd67ixup4y7s4/s3translator-6.19-fx_signed.xpi
  • Step 2.
    Download the latest (now it is 6.24) unsigned version:
    https://www.dropbox.com/s/8e45m9jhu5usruz/s3translator_6.24.xpi
  • Step 3.
    in the address bar of Firefox: about:debugging#addons
    Click on the button “Load temporary Add-on …”
    choose the previously downloaded s3translator_6.24.xpi
  • Step 4.
    do any translation to make sure that it works
  • Step 5.
    restart firefox
    the temporary extension s3translator_6.24.xpi will automatically be removed from the browser and the previously installed s3translator-6.19-fx_signed.xpi will be restored

    BUT!!
    6.24版的 API將會被保存在6.19版的API中
    1個月過後,API的Key就會過期,必須重複執行Step3

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store